Upgrade sau downgrade la wordpress ?

fail-to-load1Eu nu ştiu cât îl mai complică inutil şi unde au de gand să ajungă cu el, dar eu am început să mă satur să tot fac pe update-uri şi să cârpesc la mizeria asta numită wordpress.

Pluginul User Online până la vers 2.50 a mers, n-a făcut probleme niciodată.

Acum câteva zile apare 2.60, versiune nouă de User Online. N-a mers.

Ziua următoare apare versiunea 2.61. Nu mergea nici asta. Trebuie sa aflu de pe un forum că de fapt merge dacă schimb codul cu care se afişază, respectiv în loc de asta:
<?php if (function_exists(‘useronline’)): ?> (şi ce urmează după)
cu asta:
<?php if (function_exists(‘get_useronline’)): ?>

L-am facut să apară dar constat altă belea. Dacă în wp-admin la setări la plugin la UserOnline URL las empty cum era şi până acum, pe Users Online pe pagină imi apare un link cretin de forma http://orq.biz/\”\”

Am pus înapoi versiunea 2.50. Sugi pula WordPress.

Cine ştie ce nenorociri mai aduce wp 2.9.2 care deja a apărut dar stau pe gânduri, nu ştiu ce să fac.
Later edit:

Este vina wordpress-ului, o să explic de ce, acum din cauza pluginului mi-a sărit mie siguranţa. De la Crăciun încoace e NUMAI vina wordpress-ului.
Cine avea nevoie de binefacerile vers 2.9? Coş de gunoi şi editare imagini mi se pare.
Ce mai au de gând să încorporeze în el? Lucrurile bune sunt întotdeauna simple.
Poate ar trebui încorporat în wordpress şi un editor video foarte complex gen Pinnacle Video Studio. Ce ziceţi?
Şi atunci îi obligă destul de des şi pe developerii ăştia mai mici să-şi updateze pluginurile.
Nu cred că există săptămână fără vreun upgrade. Şi de fiecare dată ţi se aminteşte înainte să-ţi faci back-up la baza de date şi la toate filele. Poate ştiu ei de ce. Şi atunci stai şi te întrebi, după presupusul upgrade o să-ţi mai vezi în grabă blogul up?
Dacă totul decurge ok răsufli uşurat.

Faptul că un soft este free nu este o scuză pentru a n-i se oferi rahat, poate dacă ar exista şi versiune premium care am refuzat-o, aş mai înţelege.

Pentru nefuncţionarea pluginului respectiv e vinovat şi wordpress-ul din moment ce îl promovează. Eu de acolo l-am descărcat, din wordpress.org/extend/plugins/. Dacă măcar o persoană din cadrul wordpress s-ar fi sinchisit să facă un test de 5 minute, nu ar fi ajuns să se publice pe site-ul oficial două versiuni succesive de plugin nefuncţional.
Cei de la wordpress se spală pe mâini că e vina developerului, iar cel în cauză se scuză că s-a angajat full-time şi nu mai are timp de joacă.

De asta-i faină să fie open source si free. Lucră toţi da’ nu răspunde nimeni.

Add a Comment